diff immposiblerush/PKG/PKGBUILD @ 9:cdadbf30a821

arkanoid-0.7-1_PKG
author prymula <prymula76@outlook.com>
date Sun, 04 Feb 2024 15:47:05 +0100
parents 923377f8ebcb
children 4dc186728822
line wrap: on
line diff
--- a/immposiblerush/PKG/PKGBUILD	Sat Feb 03 18:23:04 2024 +0100
+++ b/immposiblerush/PKG/PKGBUILD	Sun Feb 04 15:47:05 2024 +0100
@@ -1,21 +1,23 @@
 # Maintainer: Przemyslaw R. Pietraszczyk <prymula76@outlook.com>
+
 pkgname=immposiblerush
 pkgver=0.230919
 pkgrel=0
-pkgdesc="atch the color on the square in such a way that it matches the color of the ball. Control, key 'A' - turn left, key 'D' - turn right."
+pkgdesc="Match the color on the square in such a way that it matches the color of the ball. Control, key 'A' - turn left, key 'D' - turn right."
 arch=('any')
 url="prymula.ct8.pl"
-license=('GPL')
+license=('GPL3')
+provides=('immposiblerush')
 depends=('jdk-openjdk')
 makedepends=('jdk-openjdk' 'ant')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::file://$pkgname-$pkgver-$pkgrel.tar.gz")
-sha256sums=('3dee0cbe55a1ab66dc7a51c82e314dc8c6809851c3a1027bae5ad6cee6eb25b9') #generate with 'makepkg -g'
+source=("${pkgname}-${pkgver}-${pkgrel}.tar.gz::file://${pkgname}-${pkgver}-${pkgrel}.tar.gz")
+sha256sums=('4035729dde8b7f4c1547558257913391949b8c00c0c87aca5d403adb9c651ddf') #generate with 'makepkg -g' || sha256sum
 build() {
-	cd "$srcdir/$pkgname-$pkgver-$pkgrel"
+	cd "$srcdir/${pkgname}-${pkgver}-${pkgrel}"
 	make -f Makefile.aur
 }
 
 package() {
-	cd "$srcdir/$pkgname-$pkgver-$pkgrel"
+	cd "$srcdir/${pkgname}-${pkgver}-${pkgrel}"
 	make -f Makefile.aur DESTDIR="${pkgdir}" install
 }